请选择 进入手机版 | 继续访问电脑版

LibreOffice中文社区

 找回密码
 马上加入

QQ登录

只需一步,快速开始

扫一扫,访问微社区

搜索
开启左侧

[问题] 从5.4起,Base会使用firebird数据库引擎?

[复制链接]
grassvalley 发表于 2017-8-24 17:42:35 | 显示全部楼层 |阅读模式
在部分网站上看到,说从LibreOffice 5.4起,将使用firebird数据库引擎代替目前的HSQLDB数据库引擎,目的是为了拜托对java运行环境的依赖。
目前LibreOffice除了Base组件外,其他都已经摆脱了Java依赖。

但是我下载LibreOffice5.4的windows版本,选择新建数据库,对话框出现的依然是HSQLDB。

难道传言是假的?或者替换工作遇到困难,延期了?

ACTom 发表于 2017-8-25 08:40:06 | 显示全部楼层
5.4中新建是可以选择Firebird还是HSQLDB的,只是默认还是HSQLDB
 楼主| grassvalley 发表于 2017-8-25 09:28:51 | 显示全部楼层
你用的什么版本?Linux版吗?我为什么在下拉框里只看到一个HSQLDB的选项?
 楼主| grassvalley 发表于 2017-8-25 16:44:27 | 显示全部楼层
我下载了Linux版本的LibreOffice,在新建数据库对话框的 内嵌数据库 类型 选择下拉框里,依然是只有HSQLDB一个选项。
Kiev 发表于 2017-8-25 20:15:59 来自手机 | 显示全部楼层
点击工具→选项→高级→启用实验功能,然后重启,这样就能用上 Firebird。
 楼主| grassvalley 发表于 2017-8-28 08:42:55 | 显示全部楼层
按照楼上所说,是可以启用firebird数据库引擎的。不过我试了一下,还是有问题的,我试图将原来的数据库内容导入到新的数据库,失败了。
我打开以firebird新数据库,再打开hsqldb老数据库,从老数据库复制一个表粘贴到新数据库,出现setstring类型转换错误,setvalue类型转换错误。
我有见了一个简单的表,然后在calc中输入了一些内容,再用复制粘贴的办法导入,仍然发生错误,但是提示信息不记得了,不过数据倒是复制过去了。
*滑块验证:
您需要登录后才可以回帖 登录 | 马上加入

本版积分规则

小黑屋|手机版|Archiver|LibreOffice中文社区 ( 粤ICP备13080851号-4 )  

GMT+8, 2017-11-20 03:25 , Processed in 0.086894 second(s), 22 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表